読者です 読者をやめる 読者になる 読者になる

やったこと

webサービスを作るときに考えたことを垂れ流します

phpのgoto文はバージョン5.3以降じゃないと使えないのか

phpでgoto文を書いたらエラー吐いて実行できなくて困った。

なんでだろうって思って調べてみたら、phpのgoto文はバージョン5.3以降じゃないと使えないっぽかった!

php5.3は、2009年6月30日にリリースされたバージョンっぽいから、かなり最近入った機能なのね。

自分は開発するときさくらのレンサバを使ってて、古いphpが入ったのをそのまま使ってたっぽい。

開発環境と本番環境が違うと、こんな感じの間違いがいろいろ起きそうでなんかこわいな。

ちゃんと環境合わせておこ。。