読者です 読者をやめる 読者になる 読者になる

やったこと

webサービスを作るときに考えたことを垂れ流します

yum updateがエラー吐くようになってしまった

久しぶりにyum updateしたら以下のエラーが出て失敗するようなってしまった。

Error: Package: perl-IO-Compress-2.052-1.el6.rfx.noarch (rpmforge-extras)
           Requires: perl(Compress::Raw::Zlib) = 2.052
           Removing: 1:perl-Compress-Raw-Zlib-2.020-127.el6.x86_64 (@anaconda-CentOS-201207061011.x86_64/6.3)
               perl(Compress::Raw::Zlib) = 2.020
           Updated By: 1:perl-Compress-Raw-Zlib-2.021-136.el6.x86_64 (base)
               perl(Compress::Raw::Zlib) = 2.021
           Available: perl-Compress-Raw-Zlib-2.030-1.el6.rfx.x86_64 (rpmforge-extras)
               perl(Compress::Raw::Zlib) = 2.030
           Available: perl-Compress-Raw-Zlib-2.033-1.el6.rfx.x86_64 (rpmforge-extras)
               perl(Compress::Raw::Zlib) = 2.033
           Available: perl-Compress-Raw-Zlib-2.034-1.el6.rfx.x86_64 (rpmforge-extras)
               perl(Compress::Raw::Zlib) = 2.034
           Available: perl-Compress-Raw-Zlib-2.035-1.el6.rfx.x86_64 (rpmforge-extras)
               perl(Compress::Raw::Zlib) = 2.035
           Available: perl-Compress-Raw-Zlib-2.037-1.el6.rfx.x86_64 (rpmforge-extras)
               perl(Compress::Raw::Zlib) = 2.037
           Available: perl-Compress-Raw-Zlib-2.051-1.el6.rfx.x86_64 (rpmforge-extras)
               perl(Compress::Raw::Zlib) = 2.051
           Available: perl-Compress-Raw-Zlib-2.052-1.el6.rfx.x86_64 (rpmforge-extras)
               perl(Compress::Raw::Zlib) = 2.052
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest


なにやらperl-IO-Compressというのがバージョン不一致で悪さをしている様子。

yum erase perl-Compress-Raw-Zlib」を実行して再度yum updateしたらうまくいくようなった。

自分はそもそもyumがどういうシステムなのかあんまし理解してないとこあるから、このへんちゃんと勉強しないといけないな。。